Cambios y errores

ACTUALIZADO 27-02-2006

Estoy trabado, que se le va a hacer. Me he dado cuenta de que he puesto atuomatizado en vez de automatizado, y hasta ahora no lo he visto. Es verdad la teoria esa de que leemos lo que esperamos leer. Por otro lado, me avisan de que he metido la pata, con que no es libxfont, es libxfont1. Además los paquetes han cambiado de nombre, intentaré mantener el siguiente script actualizado, pero no prometo nada.

#Bajar los paqueteswget http://download.opensuse.org/distribution/SL-OSS-factory/inst-source/suse/i586/xgl-cvs_060216-2.i586.rpmwget http://download.opensuse.org/distribution/SL-OSS-factory/inst-source/suse/i586/compiz-0.0.2-3.i586.rpmwget http://download.opensuse.org/distribution/SL-OSS-factory/inst-source/suse/i586/libsvg-cairo-0.1.6-6.i586.rpmwget http://download.opensuse.org/distribution/SL-OSS-factory/inst-source/suse/i586/libsvg-0.1.4-6.i586.rpm#Pasarlos a .debsudo apt-get install aliensudo alien *.rpm#Instalarlossudo dpkg -i xgl*.debsudo dpkg -i compiz*.debsudo dpkg -i libsvg-cairo*.debsudo dpkg -i libsvg?0*.deb#Lo que necesitan (al menos en mi caso) para ejecutarsesudo apt-get install libxfont1sudo apt-get install gconf-editor #no es necesario pero si muy recomendablecd /usr/X11R6/lib/X11sudo ln -s ../../../share/X11/fonts fonts #En vez de esto, se puede llamar a Xgl con la opcion -fp /usr/share/X11/fonts#sudo cp /usr/lib/libdrm.so.1 /usr/lib/libdrm.so.2#Mejor que eso es:wget http://archive.ubuntu.com/ubuntu/pool/main/libd/libdrm/libdrm2_2.0-0ubuntu1_i386.debsudo dpkg -i libdrm*.debsudo apt-get install libwnck18sudo apt-get install libglitz1sudo apt-get install libpng3#Ejecutarlo#sudo Xgl :1 & sleep 5 ;DISPLAY=:1 startkde & sleep 30 ; DISPLAY=:1 compiz --replace gconf decoration wobbly fade minimize cube rotate zoom scale move resize place switcher & sleep 5 ; DISPLAY=:1 gnome-window-decorator#Las opciones que añado son las indicadas en http://en.opensuse.org/Using_Xgl_on_SUSE_Linux para mi tarjeta#quito gconf de las opciones de compiz porque crea una violacion de segmento. #Cambiando el plugin por el anteriro que si funcionaba pasa lo mismo.#El problema sera de compiz, supongo.sudo Xgl :1 -accel glx:pbuffer -accel xv:fbo& sleep 5 ;DISPLAY=:1 startkde & sleep 30 ; DISPLAY=:1 compiz --replace decoration wobbly fade minimize cube rotate zoom scale move resize place switcher & sleep 10 ; DISPLAY=:1 gnome-window-decorator

Un saludo, ahora si que tiene que estar todo

PD: Aun no he instalado esos paquetes, hasta que no pase el finde no instalo nada, que hay momentos para la fiesta y momentos para lo demas, pero supongo que todo sea igual.

Autor: Javi López

Arquitecto/desarrollador, creativo, buscador de nuevas soluciones y modelos de negocio, crítico constructivo y ex muchas cosas