Pasos para instalar Xgl

Al principio todo era oscuridad, y acabó habiendo luz. Aquí pasa lo mismo, al principio todo iba a ser escueto, anotaciones chorras donde expresara algun parecer en pocas palabras. Además pensaba mantener lo tecnológico alejado, en /., y ahora parece que va a ser que no. Al fin y al cabo si no escribiese nada sobre tecnología, programación o lo que fuese, no escribiría casi nunca, y es inevitable a veces no ser escueto, pues no se puede resumir mas, y aunque lo partiese en secciones no tendria sentido si no se leyese todo el conjunto.

Seguro que ya habeis oído hablar de Xgl un gestor de ventanas (¿o el gestor es compiz y xgl es el servidor? que mas da) para linux (o GNU/linux me da lo mismo que lomismo meda) que liberó novell hace unos días. Seguro que tambien habreis visto los asombrosos vídeos, yo cuando vi el del lanzamiento de compiz escalofríos y todo ¡oiga! tenía por la espalda. Así que como no hay nada (que yo halla visto) en español que diga como instalarlo, y como no tengo otro huevo mejor que rascar, vamos a ello (aviso que no soy ningún experto en esto y puede ser que todo salga mal)

Sigue en la pagina de la anotación.

¿De donde parto? empiezo de una kubuntu mas o menos recién instalada (petó durante los exámenes un disco duro, así que reinstale sin meter mas). Lo único que le he metido ha sido el hugs que ahora mismo ni os viene ni os va, y el automatix como indican en la pagina. Con este no tuve muchos miramientos, marque todas las opciones a ver que pasaba, pero peto cuando estaba reinstalando open office, a saber porque lo reinstalaba. La cosa es que los drivers (a pesar de haber marcado también los de ATI) si los instalo bien (tengo una nVidia). Aun así, si sois pacientes, leeros las opciones.

Al mirar que había en ingles, vi que dicen (creo, aun no me lo he leido, solo lo he mirado muy por encima) que sólo se puede instalar en dapper, así que lo pongo a bajar mientras pruebo otras cosillas. Tardara un par de horas al menos, así que no hay prisas.

Vamos a la pagina de suse sobre Xgl y ¡o sorpresa!, tienen paquetes preparados para instalar Xgl y compiz. Pos a ver si hay suerte, y no hay que tirar del cvs (aunque seguro que ahí está mas actualizado) como hacía el tío de los foros (no se porque me da que al final acabaré haciendo todo lo que el dice). Pos bueno, a descargarlos y a probar.

Son rpm, estos no encajan en un derivado debian. Pregunto a tito google y me dice que instale rpm, pero cuando ejecuto rpm *.rpm me dice que soy idiota y que use un tal alien, así que lo instalo también y este me los pasa a paquetes .deb, estos si son para debian 😉 Ejecuto dpkg -i x*.deb y lo mismo para el compiz. Ahora a ver si tiran…

Anotación 2
He mentido un poco mas arriba. No me acordaba ya, de que anoche, como tenía una kubuntu dapper (estoy bajando la otra porque el compiz tiene cosas especificas para gnome) la meti como repositorio y di a actualizar, y para variar peto a mitad (aquí todo peta). Esto lo hice porque no encontraba el directorio X11R6 donde se instalaba el Xgl. Ahora no se si es que lo estaba buscando mal o es que no estaba. La cosa es que al ir a ejecutar Xgl, me ha dicho que no encontraba libXfont, y al decirle al adept (que poco me gusta este programa) que instalase libxfont1, me ha desinstalado medio sistema, y no se si ha sido por la libreria o por el chasco del dapper. Ahora me dice que el servidor ya esta activo, pero antes de hacer nada mas con el Xgl tendré que dejar el sistema como antes, digo yo. Seguire informando…

Anotacion 3
Todo estaba muy inestable, asi que acabé rehaciendo todo. Ahora puedo decir que el problema fue por jugar con el disco del dapper drake. Los pasos que he dado, y así resumimos todo lo anterior son:

  • Instalar kubuntu
  • Instalar automatix:
    sudo apt-get remove automatix-kubuntusudo apt-get install xterm libglade2-0 libgnomecanvas2-0wget http://kambing.vlsm.org/ubuntu/pool/main/z/zenity/zenity_2.10.0-0ubuntu1_i386.debsudo dpkg -i zenity_2.10.0-0ubuntu1_i386.debwget http://est.unileon.es/jorgev/hack/automatix/automatix_sp_5.3-3_i386.debsudo dpkg -i automatix_sp_5.3-3_i386.deb
  • Ejecutar Automatix, e iinstalar las siguientes opciones:
    • Multimedia codecs
    • Firefox Plugins
    • MS TTF Fonts
    • Archives
    • Acrobat Reader
    • Ripper and Tuner
    • File Sharing
    • Multimedia Editing
    • DVD Ripper
    • Mplayer with plugin
    • Media Players
    • Debian Menu
    • Avidemux
    • Programming Tools
    • AUD-DVD codecs
    • SUN JAVA 1.5 JRE
    • SUN JAVA 1.5 SDK
    • Wine
    • Eject CD from Drive
    • AMSN 0.95
    • DMA ON
    • NVIDIA cards
    • Midi capability
    • Firefox 1.5
  • Reiniciar
  • Bajar los paquetes de Xgl y de compiz
  • Actualizar todo el sistema con adept (hay un error asi que instalo synaptic con adept)
  • Instalar alien con synaptic
  • Actualizar el sistema con synaptic
  • sudo alien *.rpm
  • sudo dpkg -i x*.deb
  • sudo dpkg -i c*.rpm
  • sudo Xgl, y como antes falta libXfont
  • Instalar libxfont1 con synaptic (no me desinstala medio sistema)
  • sudo Xgl, ya hay un servidor en marcha

Así ya vuelve a estar todo encaminado. No tocaré nada mas hasta mañana que tengo otros compromisos que cumplir.

Un saludo, volveré con mas

Pd: Me juego mil, a que acabo haciendo lo que hace el tío de los foros de ubuntu….

Autor: Javi López

Arquitecto/desarrollador, creativo, buscador de nuevas soluciones y modelos de negocio, crítico constructivo y ex muchas cosas