Ejecutando Xgl

Ayer lo dejamos con el Xgl mas o menos preparado. Al ejecutarlo decia que ya hay un servidor en ejecucion en el display 0. Ahora tenemos 3 opciones:

  • Parar o matar kdm
  • Ejecutarlo en otro display, con lo que se nos abre una vena donde lo carga.
  • Ejecutarlo en otro display desde una consola de texto para que se abra a pantalla completa

Yo opto por la tercera. Ctrl+Alt+F1 y sudo Xgl :1, y nos dice “...Could not open default font 'fixed'...". Evidentemente si no hay un directorio fonts en /usr/X11R6/lib/X11/fonts/ dificil que encuentre ninguna fuente. Mirando en /etc/X11/xorg.config veo que las fuentes están en /usr/share/X11/fonts/. Como no se (de momento) como decirle a Xgl que busque en donde debe, intento hacer un enlace pero link me dice que la operacion no esta permitida (siempre pense que root era todo poderoso ;), así que sin complicaciones copio la carpeta del tiron. Ahora si se ejecuta Xgl.

Ir va, sin embargo… si hacemos un DISPLAY=:1 xterm o mejor aun DISPLAY=:1 startkde (1 si habiamos hecho Xgl :1vemos que el interior de las ventanas sale en negro, aunque si habro konsole en el kde, los nombres de los menus y eso si se ven. Puede que halla que pasarle algun parametro o que simplemente no consiga hacerlo marchar bien... De todos modos, el siguiente paso va a ser intentar hacer funcionar el compiz que me dice que no ve libdrm, y el paquete si está instalado.

Un saludo, ahora si creo que será posible...

PD: si alguien sabe porque pasa eso con el link le agradecería la información.

Autor: Javi López

Arquitecto/desarrollador, creativo, buscador de nuevas soluciones y modelos de negocio, crítico constructivo y ex muchas cosas